class Gem::Resolver::InstallerSet

A set of gems for installation sourced from remote sources and local .gem files

Public Class Methods

new(domain) click to toggle source

Creates a new InstallerSet that will look for gems in domain.

Calls superclass method BasicObject::new
# File lib/rubygems/resolver/installer_set.rb, line 37
def initialize(domain)
  super()

  @domain = domain

  @f = Gem::SpecFetcher.fetcher

  @always_install      = []
  @ignore_dependencies = false
  @ignore_installed    = false
  @local               = {}
  @local_source        = Gem::Source::Local.new
  @remote_set          = Gem::Resolver::BestSet.new
  @force               = false
  @specs               = {}
end

Public Instance Methods

add_always_install(dependency) click to toggle source

Looks up the latest specification for dependency and adds it to the always_install list.

# File lib/rubygems/resolver/installer_set.rb, line 58
def add_always_install(dependency)
  request = Gem::Resolver::DependencyRequest.new dependency, nil

  found = find_all request

  found.delete_if do |s|
    s.version.prerelease? and not s.local?
  end unless dependency.prerelease?

  found = found.select do |s|
    Gem::Source::SpecificFile === s.source or
      Gem::Platform::RUBY == s.platform or
      Gem::Platform.local === s.platform
  end

  found = found.sort_by do |s|
    [s.version, s.platform == Gem::Platform::RUBY ? -1 : 1]
  end

  newest = found.last

  unless @force
    found_matching_metadata = found.select do |spec|
      metadata_satisfied?(spec)
    end

    if found_matching_metadata.empty?
      if newest
        ensure_required_ruby_version_met(newest.spec)
        ensure_required_rubygems_version_met(newest.spec)
      else
        exc = Gem::UnsatisfiableDependencyError.new request
        exc.errors = errors

        raise exc
      end
    else
      newest = found_matching_metadata.last
    end
  end

  @always_install << newest.spec
end
add_local(dep_name, spec, source) click to toggle source

Adds a local gem requested using dep_name with the given spec that can be loaded and installed using the source.

# File lib/rubygems/resolver/installer_set.rb, line 106
def add_local(dep_name, spec, source)
  @local[dep_name] = [spec, source]
end
errors() click to toggle source

Errors encountered while resolving gems

# File lib/rubygems/resolver/installer_set.rb, line 127
def errors
  @errors + @remote_set.errors
end
find_all(req) click to toggle source

Returns an array of IndexSpecification objects matching DependencyRequest req.

# File lib/rubygems/resolver/installer_set.rb, line 135
def find_all(req)
  res = []

  dep = req.dependency

  return res if @ignore_dependencies and
            @always_install.none? {|spec| dep.match? spec }

  name = dep.name

  dep.matching_specs.each do |gemspec|
    next if @always_install.any? {|spec| spec.name == gemspec.name }

    res << Gem::Resolver::InstalledSpecification.new(self, gemspec)
  end unless @ignore_installed

  if consider_local?
    matching_local = @local.values.select do |spec, _|
      req.match? spec
    end.map do |spec, source|
      Gem::Resolver::LocalSpecification.new self, spec, source
    end

    res.concat matching_local

    begin
      if local_spec = @local_source.find_gem(name, dep.requirement)
        res << Gem::Resolver::IndexSpecification.new(
          self, local_spec.name, local_spec.version,
          @local_source, local_spec.platform)
      end
    rescue Gem::Package::FormatError
      # ignore
    end
  end

  res.delete_if do |spec|
    spec.version.prerelease? and not dep.prerelease?
  end

  res.concat @remote_set.find_all req if consider_remote?

  res
end
prefetch(reqs) click to toggle source
# File lib/rubygems/resolver/installer_set.rb, line 180
def prefetch(reqs)
  @remote_set.prefetch(reqs) if consider_remote?
end
prerelease=(allow_prerelease) click to toggle source
Calls superclass method
# File lib/rubygems/resolver/installer_set.rb, line 184
def prerelease=(allow_prerelease)
  super

  @remote_set.prerelease = allow_prerelease
end

Private Instance Methods

metadata_satisfied?(spec) click to toggle source
# File lib/rubygems/resolver/installer_set.rb, line 249
def metadata_satisfied?(spec)
  spec.required_ruby_version.satisfied_by?(Gem.ruby_version) &&
    spec.required_rubygems_version.satisfied_by?(Gem.rubygems_version)
end