Ruby 2.6.0 リファレンスマニュアル > ライブラリ一覧 > rubygems/requirementライブラリ > Gem::Requirementクラス > satisfied_by?

instance method Gem::Requirement#satisfied_by?

satisfied_by?(version) -> bool[permalink][rdoc]

引数 version が自身に含まれる全ての必要条件を満たす場合に真を返します。 そうでなければ偽を返します。

[PARAM] version:
Gem::Version のインスタンスを指定します。

[SEE_ALSO] Gem::Requirement#satisfy?