class Bundler::EndpointSpecification

used for Creating Specifications from the Gemcutter Endpoint

Constants

ILLFORMED_MESSAGE

Attributes

checksum[R]
dependencies[RW]
name[R]
platform[R]
remote[RW]
required_ruby_version[R]
required_rubygems_version[R]
source[RW]
version[R]

Public Class Methods

new(name, version, platform, dependencies, metadata = nil) click to toggle source
Calls superclass method Gem::Specification.new
# File lib/bundler/endpoint_specification.rb, line 12
def initialize(name, version, platform, dependencies, metadata = nil)
  super()
  @name         = name
  @version      = Gem::Version.create version
  @platform     = platform
  @dependencies = dependencies.map {|dep, reqs| build_dependency(dep, reqs) }

  @loaded_from          = nil
  @remote_specification = nil

  parse_metadata(metadata)
end

Public Instance Methods

__swap__(spec) click to toggle source
# File lib/bundler/endpoint_specification.rb, line 102
def __swap__(spec)
  SharedHelpers.ensure_same_dependencies(self, dependencies, spec.dependencies)
  @remote_specification = spec
end
_local_specification() click to toggle source
# File lib/bundler/endpoint_specification.rb, line 95
    def _local_specification
      return unless @loaded_from && File.exist?(local_specification_path)
      eval(File.read(local_specification_path)).tap do |spec|
        spec.loaded_from = @loaded_from
      end
    end

    def __swap__(spec)
      SharedHelpers.ensure_same_dependencies(self, dependencies, spec.dependencies)
      @remote_specification = spec
    end

  private

    def local_specification_path
      "#{base_dir}/specifications/#{full_name}.gemspec"
    end

    def parse_metadata(data)
      return unless data
      data.each do |k, v|
        next unless v
        case k.to_s
        when "checksum"
          @checksum = v.last
        when "rubygems"
          @required_rubygems_version = Gem::Requirement.new(v)
        when "ruby"
          @required_ruby_version = Gem::Requirement.new(v)
        end
      end
    rescue StandardError => e
      raise GemspecError, "There was an error parsing the metadata for the gem #{name} (#{version}): #{e.class}\n#{e}\nThe metadata was #{data.inspect}"
    end

    def build_dependency(name, requirements)
      Gem::Dependency.new(name, requirements)
    rescue ArgumentError => e
      raise unless e.message.include?(ILLFORMED_MESSAGE)
      puts # we shouldn't print the error message on the "fetching info" status line
      raise GemspecError,
        "Unfortunately, the gem #{name} (#{version}) has an invalid " \
        "gemspec.\nPlease ask the gem author to yank the bad version to fix " \
        "this issue. For more information, see http://bit.ly/syck-defaultkey."
    end
  end
end
bindir() click to toggle source

needed for bundle clean

Calls superclass method
# File lib/bundler/endpoint_specification.rb, line 63
def bindir
  if @remote_specification
    @remote_specification.bindir
  elsif _local_specification
    _local_specification.bindir
  else
    super
  end
end
build_dependency(name, requirements) click to toggle source
# File lib/bundler/endpoint_specification.rb, line 130
def build_dependency(name, requirements)
  Gem::Dependency.new(name, requirements)
rescue ArgumentError => e
  raise unless e.message.include?(ILLFORMED_MESSAGE)
  puts # we shouldn't print the error message on the "fetching info" status line
  raise GemspecError,
    "Unfortunately, the gem #{name} (#{version}) has an invalid " \
    "gemspec.\nPlease ask the gem author to yank the bad version to fix " \
    "this issue. For more information, see http://bit.ly/syck-defaultkey."
end
executables() click to toggle source

needed for binstubs

Calls superclass method Gem::Specification#executables
# File lib/bundler/endpoint_specification.rb, line 52
def executables
  if @remote_specification
    @remote_specification.executables
  elsif _local_specification
    _local_specification.executables
  else
    super
  end
end
extensions() click to toggle source

needed for “with native extensions” during install

Calls superclass method Gem::Specification#extensions
# File lib/bundler/endpoint_specification.rb, line 85
def extensions
  if @remote_specification
    @remote_specification.extensions
  elsif _local_specification
    _local_specification.extensions
  else
    super
  end
end
fetch_platform() click to toggle source
# File lib/bundler/endpoint_specification.rb, line 25
def fetch_platform
  @platform
end
load_paths() click to toggle source

needed for inline

Calls superclass method Gem::Specification#load_paths
# File lib/bundler/endpoint_specification.rb, line 42
def load_paths
  # remote specs aren't installed, and can't have load_paths
  if _local_specification
    _local_specification.load_paths
  else
    super
  end
end
local_specification_path() click to toggle source
# File lib/bundler/endpoint_specification.rb, line 109
def local_specification_path
  "#{base_dir}/specifications/#{full_name}.gemspec"
end
parse_metadata(data) click to toggle source
# File lib/bundler/endpoint_specification.rb, line 113
  def parse_metadata(data)
    return unless data
    data.each do |k, v|
      next unless v
      case k.to_s
      when "checksum"
        @checksum = v.last
      when "rubygems"
        @required_rubygems_version = Gem::Requirement.new(v)
      when "ruby"
        @required_ruby_version = Gem::Requirement.new(v)
      end
    end
  rescue StandardError => e
    raise GemspecError, "There was an error parsing the metadata for the gem #{name} (#{version}): #{e.class}\n#{e}\nThe metadata was #{data.inspect}"
  end

  def build_dependency(name, requirements)
    Gem::Dependency.new(name, requirements)
  rescue ArgumentError => e
    raise unless e.message.include?(ILLFORMED_MESSAGE)
    puts # we shouldn't print the error message on the "fetching info" status line
    raise GemspecError,
      "Unfortunately, the gem #{name} (#{version}) has an invalid " \
      "gemspec.\nPlease ask the gem author to yank the bad version to fix " \
      "this issue. For more information, see http://bit.ly/syck-defaultkey."
  end
end
post_install_message() click to toggle source

needed for post_install_messages during install

Calls superclass method
# File lib/bundler/endpoint_specification.rb, line 74
def post_install_message
  if @remote_specification
    @remote_specification.post_install_message
  elsif _local_specification
    _local_specification.post_install_message
  else
    super
  end
end
require_paths() click to toggle source

needed for standalone, load required_paths from local gemspec after the gem is installed

Calls superclass method Gem::BasicSpecification#require_paths
# File lib/bundler/endpoint_specification.rb, line 31
def require_paths
  if @remote_specification
    @remote_specification.require_paths
  elsif _local_specification
    _local_specification.require_paths
  else
    super
  end
end